Ya tenemos montado nuestro extrusor, pero como todo en la impresora, hay que configurarlo, ya que existen multitud de variaciones (ya sea por la relación de transformación entre los engranajes o por que usemos un motor u otro) que van a hacer que por cada paso que de nuestro motor extruya mas o menos plástico, por ello antes de poner el HotEnd, vamos a configurar los pasos que debe de dar nuestro motor para extruir una cantidad determinada de plástico.

Lo primero que vamos a hacer, va a ser conectar la electrónica a nuestra máquina, para ello tan solo vamos a usar la salida E0 (la del extrusor), al que conectaremos el motor que hemos colocado a nuestro extrusor. El montaje será como el de la imagen.

IMG 0298

Una vez conectada la electrónica, vamos a abrir el Pronterface y en la zona inferior, donde pone "Extrude" vamos a poner que extruya 100mm y le vamos a dar a extruir, pero antes de esto, haced una marca con un rotulador al filamento, para tenerla como referencia y saber cuánto extruye realmente.

IMG 0304pronterface

Si vemos que en lugar de sacar el filamento por abajo, lo está subiendo, cambiad el sentido del conector del motor, ya que lo tenéis invertido)

 

Al terminar de extruir, haced otra marca y cortad el filamento para poder medir la distancia entre las marcas con mayor comodidad.

Como comprobareis al medir, la distancia extruida no va a ser de 100mm (o habéis tenido mucha suerte y os vais a librar de ajustar esta parte...), por lo que tendréis que ajustar en el firmware los pasos por milímetro que da nuestro motor.

IMG 0305

Abrid el entorno de programación de Arduino (versión 0022) y cargad el Sprinter como habíamos hecho con anterioridad, id a la pestaña de configuración y buscad el parámetro "axis_steps_per_unit", donde como veréis tiene asignado 4 parámetros, uno por cada eje y los tiene asignado en el siguiente orden X, Y, Z, Extrusor. nosotros vamos a modificar el cuarto, el que hace referencia al extrusor.

sprinter2

Si habéis descargado la versión de Sprinter que tengo yo en la web, el valor asignado de este parámetro será 777.6, pues bien, para poner el valor correcto vamos a dividir este valor por la distancia REAL que hemos extruido (en mi caso ha sido 107mm) y vamos a multiplicar por la distancia que le dimos para extruir (en mi caso 100mm). El valor que resulte de estas operaciones, va a ser el que vamos a colocar en este parámetro.

Una vez cambiado este valor, tan solo debemos de cargar de nuevo el firmware en nuestro Arduino como habíamos hecho con anterioridad.

Para comprobar que el valor introducido es válido, vamos a realizar de nuevo la extrusión volviendo a medir el resultado y viendo si el valor que queremos extruir coincide realmente con el valor extruido.

IMG 0306

 

 

 

Deja tus comentarios

Enviar un comentario como invitado

0
terminos y condiciones.
Cargar Comentarios Previos
  • Invitado - Ammisaddai

    Hola, excelente el tutorial.

    Tengo un problema con el extrusor, ya tengo todo conectado y funciona bien a excepcion del extrusor olvide configurar sus parametros pero al momento de indicar que empiece extruir me sale el siguiente error ocacionando que no se miueva el motor:
    Extruding 100.000000mm of filament.
    echo: cold extrusion prevented

    Que me recomiendas hacer??

    sAludos

  • Hola, ese error te sale por el el HotEnd esta frio, para extruir debe de tener una temperatura mínima, si no se alcanza esta temperatura no te va a dejar extruir. Si estas imprimiendo con PLA calienta el extrusor hasta los 210º y si tienes ABS caliéntalo a unos 230º.
    Calentando el extrusor debería solucionarse este problema, si por algún motivo no se soluciona dímelo. Saludos!

  • Invitado - edwin

    hola Raúl, te cuento que ya tengo la impresora completamente armada gracias a ti y tus tutoriales, pero empece a tener un problema algo bastante grave, cuando estaba imprimiendo mi primera pieza el motor del extrusor dejo de funcionar y empezó a atascarse, investigue algo en Internet pero sin mucho éxito, creo que son los pasos del motor que se atascan. espero me puedas ayudar ya que me parece algo frustrante en a ver invertido tanto tiempo y dinero en algo que no funcione. gracias por tu atención y ayuda.

    de Cra. 2 #33-1 a 33-183, Soacha, Cundinamarca, Colombia
  • Hola Edwin, si no tienes refrigerado el HotEnd con un ventilador es posible que se atasque, el ventilador de HotEnd es muy importante, sin este ventilador el calor va ascendiendo poco a poco y al final llega a extruir el HotEnd, lo que produce que el motor del extrusor no tenga fuerzas para empujar el filamento.
    Desatasca todo bien, refrigera el Hotend y verás como los problemas de atasco desaparecen

  • Invitado - Maffer

    Hola Raúl, he visto que en los videos mencionas que la velocidad de extrución la cambiarías en el software final, pero en ninguno de los videos lo vuelves a mencionar, ¿será me puedas comentar donde hacer este cambio? a que mi extrusor va muy lento sacando el PLA

  • Hola, en la imagen 3 de 6 de esta misma pagina puedes ver una imagen con el proterface y una flecha roja que apunta a la cantidad de filamento extruido (100 mm) a la derecha hay una casilla donde pone "5mm/min" si cambias esto estarás cambiando la velocidad a la que el filamento sale por el extrusor

  • Invitado - Miguel Martinez

    Hola disculpa en que video explicas lo de el pronterface como se instala, descarga y configura o simplemente me lo descargo de otro lado lo abro y hago tus pasos, espero me puedas responder muchas gracias por cierto muy buen tutorial.

    de José María Morelos y Pavón 30, Zimbrones, 51350 San Miguel Zinacantepec, Méx., Mexico
  • Pronterface hay muchas versiones, muchas de ellas necesitan que tengas instalado python y que además lo intales de una forma muy especifica, si bajas el que tengo yo puesto en la WEB es auto ejecutable, no necesita instalación, tan solo descargalo y ejecútalo dando al icono que esta dentro de la carpeta . Aqui tienes el link por si no lo encuentras: https://www.zonamaker.com/descargas/Impresion3D/Sprinter.zip

  • Invitado - xavier sanchez

    Buenas tardes Raul, saludos.
    Estoy construyendo una impresora igual a la tuya pero probando el extrusor me doy cuenta que cuando le pido expulsar 10cm me expulsa 46cm muchisimo mas de lo que le coloco. y obviamente cuando coloco ese monto en la formula me queda en 126,5 y el motor se me pone muy lento. quisiera por favor me dijeras cual puede ser el error. gracias.

  • Invitado - Niana Rona

    I finished the application, notwithstanding I have quite recently begun an expert doctorate course and felt this would make additionally worry to study and working. Will there be any longer accomplices one year from now? Assignment Help Online