Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme
  • Página:
  • 1

TEMA: Eje z se desfasa 1 mm, pierde pasos

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #919

  • matias
  • Avatar de matias Autor del tema
  • Fuera de línea
  • New Member
  • New Member
  • Mensajes: 7
  • Gracias recibidas: 0
Buenas a todos!!
Ya estoy imprimiendo mis primera piezas después de configura y calibrar. La verdad que estoy contento porque creo que me salió algo jaja, pero falta más trabajo y paciencia como todo. Lo que note que me están saliendo bien en la base pero se inclinan hacia la izquierda (mirando desde el frente de la impresora). Midiendo y midiendo me di cuenta que uno de mis motores del eje z se desfasa 1 mm con respecto de otro, es el del lado derecho (mirando desde el frente de la impresora) y solo ese se desfasa y siempre 1mm, ose que pierde paso cuando acelera, cuando va a uso manual no. Al momento de calentar cama y hotend está todo bien, le doy la orden de impresión, sube y cuando vuelve a bajar (eje z) en ese momento párese que se des calibrara (me da esa impresión). Físicamente las varillas roscadas son métrica 5, y están bien, pasan bien desde el primer momento y no se traban y están bien engrasadas, no hay nada físico como para que se trabe. Ósea que mi eje z no está nivelado y queda ladeado.
Uso arduino mega, ramps 1.4 y los pololus a4988, seguí tal cual los vídeos y uso el marline de zona maker tal cual. Les dejo una foto adjuntada de como sale espero se note. El de la izquierda es la primera impresión, y la de la derecha la segunda, son cubos de calibración. Si ven en la x se nota como se deforma y achica un poco. La segunda la controle todo el tiempo y cuando se pasaba la corregía manualmente mientras imprimía, igual se achico un poco la parte superior de la x (letra). Que podría ser? espero sus respuestas!! Saludos!!



Adjuntos:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #920

  • matias
  • Avatar de matias Autor del tema
  • Fuera de línea
  • New Member
  • New Member
  • Mensajes: 7
  • Gracias recibidas: 0
se me olvido uso el repetier-host v1.6.1 con slice

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #922

  • Raúl Diosdado
  • Avatar de Raúl Diosdado
  • Fuera de línea
  • Administrator
  • Administrator
  • Mensajes: 668
  • Karma: 17
  • Gracias recibidas: 145
Para ser la primera impresión esta bastante bien, todavía se le puede sacar mas calidad, pero es muy buen comienzo.
El problema que comentas solo se me ocurre que pueda deberse a algo mecanico ya que ambos motores del eje Z estan unidos y siempre que se mueve uno se mueve el otro, por lo que descartaría todo lo que es configuración de software.
Ademas de ver que no se traben los motores deberías asegurarte que la varilla no patina en el acoplador, aprieta bien todos los tornillos.
Otro problema que puede surgir es por la tuerca que esta empotrada en la pieza de plástico por la que roscan las varillas de Z, si se mueven puede hacer que suba o baje ese milímetro que comentas y estropearte la impresión.
Un ultimo problema que pudiera darse es que por vibraciones o alguna cosa el motor girase un poco haciendo bajar la pieza, esto se puede producir ya que los motores del eje Z no están enclavados o sea que se pueden mover libremente cuando esta imprimiendo la impresora, el resto están enclavados y no permite el movimiento mientras se imprime. En el firmware tienes la opción para enclavar también estos motores cuando la impresora este en uso.
Ya me dirás si eres capaz de solucionar el problema, un saludo!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #924

  • matias
  • Avatar de matias Autor del tema
  • Fuera de línea
  • New Member
  • New Member
  • Mensajes: 7
  • Gracias recibidas: 0
Buenas a todos!
Estuve revisando y seguí tus consejos y en efecto tenia algunos problemas. primero que nada uno mecánico como sugeriste. el problema esta en los motores del eje z, que no tiene un buen torque, desarme los acoples y solo con la mano los podía detener haciendo poca presión, intente colocarle mas potencia desde los pololus pero nada. por lo que cambie la aceleración, de 3.3 a 1, y de esta manera logro de que pueda con el peso de eje, y no me pierda pasos. seguramente tendré que cambiar los motores mas adelante. después la mesa donde estoy trabajando tampoco esta tan plana, puse un nivel de burbuja y se ladea hacia un lado.
quisieras que me digas como nivelar, la cama y el eje z, con respecto a la mesa, que tengo que tener en cuenta?, dejo que el marco y la mesa ladeada, y nivelo la cama y el eje, por su lado con un nivel? disculpa por la pregunta si es obvia pero realmente no lo se. muchas gracias!!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #925

  • Raúl Diosdado
  • Avatar de Raúl Diosdado
  • Fuera de línea
  • Administrator
  • Administrator
  • Mensajes: 668
  • Karma: 17
  • Gracias recibidas: 145
Buenos días, asegúrate que el problema de potencia de los motores no es debido a que intentan girar muy rápidos o a que los pololus le entregan poca corriente, en algunas ocasiones ajustando un poco los pololus y la velocidad de giro es suficiente y con eso te ahorras el comprar piezas.
Mira bien la referencia de los motores que usas, hay algunos que dan muy poca potencia, aunque en el eje Z no suele ser un problema, el problea por potencia en estos motores suele ser debido a los pololus.
En cuanto a la nivelación, no te preocupes si la mesa esta desnivelada, porque al estar desnivelada toda la impresora lo estará y no afecta a la impresión. Tu debes centrarte en nivelar la cama con respecto al eje X, si consigues que el eje X y la cama estén totalmente paralelos luego tan solo debes ajustar la altura del eje Z (para que se detenga la boquilla del HotEnd a unos 0.2mm de la base) y dar pequeños retoques en los tornillos de la cama hasta conseguir que la boquilla del HotEnd esté a la misma distancia en todos los puntos de la cama.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #926

  • matias
  • Avatar de matias Autor del tema
  • Fuera de línea
  • New Member
  • New Member
  • Mensajes: 7
  • Gracias recibidas: 0
Buenas a todos!
si efectivamente mis motores giraban muy rápidos, baje la aceleración y muy bien!! mil gracias por tu tiempo. calibre la cama y el eje x como dijiste y bien. empece a imprimir y mucho mejor, no pierde paso ni nada. luego de unos cubos me puse a hacer unas piezas mejoradas para la misma impresora y mi di cuenta de algo, que estaba imprimiendo espejado todo el tiempo. en los cubos no me di ni cuenta pero es piezas distinta si. mire en la Internet y dicen lo de los motores invertidos y los finales de carrera, pero yo ya lo escribí en el marline, de que invierta los eje x, e y , (prusa i3 rework), pero no pasa nada. no se que mas tocar o modificar para que imprima como me lo muestra el repetir, no se si modificar el marline o el repetier. el firm es de zona maker, y los finales de carreras están tal cuales, probé dejando por defecto todo y cambiando la polaridad de los motores y nada. lo que creo entender (si esta mal me lo haces saber) que el firm tiene el punto de origen o los 0.0 en el lado izquierdo de la impresora pero en la rework esta en el derecho, y eso creo que es lo que tengo que cambiar y no se como (creo que eso jeje) corregidme si estoy en lo incorrecto. espero tu respuesta, mil gracias!!! saludos!!!!!!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #927

  • Raúl Diosdado
  • Avatar de Raúl Diosdado
  • Fuera de línea
  • Administrator
  • Administrator
  • Mensajes: 668
  • Karma: 17
  • Gracias recibidas: 145
Hola!! me alegro que solucionaras el problema de los motores. Hay un tema abierto sobre el problema que comentas de imprimir en espejo, creo que te será útil esto:
www.zonamaker.com/foro/consultas-impresi...ce-imprime-en-espejo
Si tienes cualquier otro problema dímelo y te echo una mano, un saludo!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #928

  • matias
  • Avatar de matias Autor del tema
  • Fuera de línea
  • New Member
  • New Member
  • Mensajes: 7
  • Gracias recibidas: 0
Buenas a todos!
estuve viendo el enlace que me dejaste y lo analice una y otra vez y esta muy claro, y me pasa lo mismo los puntos de Home son x 190 y 170, el problema es que no se donde modificaros en el marline. busque y no encuentro donde, o no lo veo jeje. y no me quedo bien claro lo de los finales de carrera que marca ese enlace, tengo que cambiarlos como muestra el esquema que puso Valvulin? yo los tengo tal cual Zona Maker. Gracias!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Eje z se desfasa 1 mm, pierde pasos 3 años 4 meses antes #931

  • Raúl Diosdado
  • Avatar de Raúl Diosdado
  • Fuera de línea
  • Administrator
  • Administrator
  • Mensajes: 668
  • Karma: 17
  • Gracias recibidas: 145
Hola, En el caso de Valvulin el cambio la posición del final de carrera en el EJE X, tu dejalo como en los tutoriales (es lo mas común).
Antes de configurar nada asegurate que tienes conectado los finales de carrera en la posición mínima de cada eje, esto es para el final de carrera de X la posición 1, para el de Y, la posición 3 y para el de Z la posición 5.
Una vez Hecho esto vamos con el firmware, abre el marlin y ve a la pestaña de configuración, y llegarás a una parte donde verás esto:

//===========================================================================
//=============================Mechanical Settings===========================
//===========================================================================

// Uncomment the following line to enable CoreXY kinematics
// #define COREXY

// corse Endstop Settings
#define ENDSTOPPULLUPS // Comment this out (using // at the start of the line) to disable the endstop pullup resistors

#ifndef ENDSTOPPULLUPS
// fine Enstop settings: Individual Pullups. will be ignord if ENDSTOPPULLUPS is defined
#define ENDSTOPPULLUP_XMAX
#define ENDSTOPPULLUP_YMAX
#define ENDSTOPPULLUP_ZMAX
#define ENDSTOPPULLUP_XMIN
#define ENDSTOPPULLUP_YMIN
//#define ENDSTOPPULLUP_ZMIN
#endif

#ifdef ENDSTOPPULLUPS
#define ENDSTOPPULLUP_XMAX
#define ENDSTOPPULLUP_YMAX
#define ENDSTOPPULLUP_ZMAX
#define ENDSTOPPULLUP_XMIN
#define ENDSTOPPULLUP_YMIN
#define ENDSTOPPULLUP_ZMIN
#endif

// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
const bool X_ENDSTOPS_INVERTING = true; // set to true to invert the logic of the endstops.
const bool Y_ENDSTOPS_INVERTING = true; // set to true to invert the logic of the endstops.
const bool Z_ENDSTOPS_INVERTING = true; // set to true to invert the logic of the endstops.
//#define DISABLE_MAX_ENDSTOPS

// For Inverting Stepper Enable Pins (Active Low) use 0, Non Inverting (Active High) use 1
#define X_ENABLE_ON 0
#define Y_ENABLE_ON 0
#define Z_ENABLE_ON 0
#define E_ENABLE_ON 0 // For all extruders

// Disables axis when it's not being used.
#define DISABLE_X false
#define DISABLE_Y false
#define DISABLE_Z true
#define DISABLE_E false // For all extruders

#define INVERT_X_DIR false // for Mendel set to false, for Orca set to true
#define INVERT_Y_DIR false // for Mendel set to true, for Orca set to false
#define INVERT_Z_DIR true // for Mendel set to false, for Orca set to true
#define INVERT_E0_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E1_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E2_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false

// ENDSTOP SETTINGS:
// Sets direction of endstops when homing; 1=MAX, -1=MIN
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1

#define min_software_endstops true //If true, axis won't move to coordinates less than HOME_POS.
#define max_software_endstops true //If true, axis won't move to coordinates greater than the defined lengths below.
// Travel limits after homing
#define X_MAX_POS 190
#define X_MIN_POS 0
#define Y_MAX_POS 180
#define Y_MIN_POS 0
#define Z_MAX_POS 180
#define Z_MIN_POS 0

#define X_MAX_LENGTH (X_MAX_POS - X_MIN_POS)
#define Y_MAX_LENGTH (Y_MAX_POS - Y_MIN_POS)
#define Z_MAX_LENGTH (Z_MAX_POS - Z_MIN_POS)

// The position of the homing switches
//#define MANUAL_HOME_POSITIONS // If defined, MANUAL_*_HOME_POS below will be used
//#define BED_CENTER_AT_0_0 // If defined, the center of the bed is at (X=0, Y=0)

//Manual homing switch locations:
#define MANUAL_X_HOME_POS 0
#define MANUAL_Y_HOME_POS 0
#define MANUAL_Z_HOME_POS 0

//// MOVEMENT SETTINGS
#define NUM_AXIS 4 // The axis order in all axis related arrays is X, Y, Z, E
#define HOMING_FEEDRATE {2000, 2000, 100, 0} // set the homing speeds (mm/min) [50*60,50*60, 4*60, 0]


Repasa en tu firmware que todo esté igual, pero en lo que debes tener especial atención es en:

#define INVERT_X_DIR false // for Mendel set to false, for Orca set to true
#define INVERT_Y_DIR false // for Mendel set to true, for Orca set to false
#define INVERT_Z_DIR true // for Mendel set to false, for Orca set to true

// Sets direction of endstops when homing; 1=MAX, -1=MIN
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: por Raúl Diosdado.
  • Página:
  • 1
Tiempo de carga de la página: 1.697 segundos